Advertisement
Advertisement


How do you overcome the svn 'out of date' error?


Question

I've been attempting move a directory structure from one location to another in Subversion, but I get an Item '*' is out of date commit error.

I have the latest version checked out (so far as I can tell). svn st -u turns up no differences other than the mv commands.

2015/03/06
1
339
3/6/2015 11:00:34 PM

Accepted Answer

I sometimes get this with TortoiseSVN on windows. The solution for me is to svn update the directory, even though there are no revisions to download or update. It does something to the metadata, which magically fixes it.

2008/09/17
643
9/17/2008 9:52:50 PM

After trying all the obvious things, and some of the other suggestions here, with no luck whatsoever, a Google search led to this link (link not working anymore) - Subversion says: Your file or directory is probably out-of-date

In a nutshell, the trick is to go to the .svn directory (in the directory that contains the offending file), and delete the "all-wcprops" file.

Worked for me when nothing else did.

2013/12/08

I believe this problem is coming from the .svn file. It's either incorrect in the old parent, the new parent or the old one. I would try reverting back to your starting point. Use an export to get a clean copy of the folder. Move the clean copy to the new location, and use an add and delete to do the move. That's manually doing what SVN does, but it might work.

2008/09/17

I've found that this works for me:

svn update
svn resolved <dir>
svn commit
2013/01/19

Tried to update the local copy, and revert the item in question, and still got the 'out of date' error. This worked for some reason:

svn update --force /path/to/dir/or/file
2011/05/18

I just had the same problem in several folders and this is what I did to commit:

1) In "Team Synchronize" perspective, right click on the folder > Override and Update
2) Delete the folder again
3) Commit and be happy

2013/10/31

Source: https://stackoverflow.com/questions/87950
Licensed under: CC-BY-SA with attribution
Not affiliated with: Stack Overflow
Email: [email protected]