Advertisement
Advertisement


Error "The connection to adb is down, and a severe error has occurred."


Question

I've spent days trying to launch any Android program. Even "Hello World" gives me the same error:

"The connection to adb is down, and a severe error has occurred".

I'm running Eclipse v3.5 (Galileo), Google APIs 2.2.8, on a Windows XP machine.

I've used all the tricks I can find on the web: the command line "adb kill-server", the DDMS "reset ADB", I started the emulator both before and after Eclipse, and searched for ports being used by other programs.

What is going on here? Is there a magic combination of versions of Eclipse, Java, ADB, emulator, and whatever else that works?

2017/11/19
1
290
11/19/2017 7:18:27 PM

Accepted Answer

Try the below steps:

  1. Close Eclipse if running
  2. Go to the Android SDK platform-tools directory in the command prompt
  3. Type adb kill-server (Eclipse should be closed before issuing these commands)
  4. Then type adb start-server
  5. No error message is thrown while starting the ADB server, then ADB is started successfully.
  6. Now you can start Eclipse again.

It worked for me this way.

Restart your phone as well!

2017/11/19
532
11/19/2017 7:20:15 PM

Use:

Open Task Manager → Processes → adb.exe → End Process → restart Eclipse

This worked for me.

And:

Open Task Manager → Processes → eclipse.exe → End Process → restart Eclipse

2017/11/19

Open up the Windows task manager, kill the process named adb.exe, and re-launch your program.

2017/11/19

[2012-07-04 11:24:25 - The connection to adb is down, and a severe error has occurred.
[2012-07-04 11:24:25 - You must restart adb and Eclipse.
[2012-07-04 11:24:25 - Please ensure that adb is correctly located at '/home/ASDK/platform-tools/adb' and can be executed

I realized the folder of the project in Eclipse was closed. I expanded the directory and the project launched. I know this may sound like a "no-brainer". I had the .java files open on the workspace, and that was enough to make me think the project was open.

2017/12/17

I tried this using Eclipse Juno and it worked fine:

  • From the dropdown of the Run icon, select option Run Configuration.
  • Make sure your project is selected
  • Go to tab Android
  • Under section Launch Action, select Launch Select the package name and voila! try running your application.

UPDATE: It also helps to kill the process adb.exe from the task manager and restart it. adb.exe can be found here: Android\android-sdk\platform-tools.

Good luck

2012/10/20

Update your Eclipse Android development tools. It worked for me.

2017/11/19

Source: https://stackoverflow.com/questions/4072706
Licensed under: CC-BY-SA with attribution
Not affiliated with: Stack Overflow
Email: [email protected]