Advertisement
Advertisement


I can't install intel HAXM


Question

I installed Android Studio and I had no problems with that. However, when I tried to run the emulator, it said that Intel HAXM was not installed.

So I found the installer, ran it, and it even though it said my laptop supports it, that it was not enabled. I went, enabled the Intel Virtualization Technology (VT-x), but I still got the same message.

I hear something about Hyper-V needs to be disabled, but when I go to Turn Windows features on/off, I cannot find it on that list.

Can someone help me with this?

2018/11/24
1
124
11/24/2018 7:30:38 PM

Accepted Answer

Alright, so I did everything I could possibly find online, and nothing worked.

So I went to the Intel website, and I downloaded the HAXM installer that they provide (instead of using the one downloaded through Android Studio).

The installation actually went through with this installer and it was installed successfully. Then I open Android Studio, and the emulator finally loaded!

So, for anyone else having this problem, just download the installer directly from the Intel website.

Here's the link:

https://software.intel.com/en-us/android/articles/intel-hardware-accelerated-execution-manager

2019/09/28
177
9/28/2019 6:03:03 PM

I think your problem was that you thought that the installer in Android SDK Manager would actually INSTALL the Intel HAXM. But the hook is that it WILL NOT INSTALL it. What it does is extracts the files needed for (really) install Intel HAXM.

I found that out when I got the same problem and then read this in Intel's web page:

Downloading through Android* SDK Manager

... Other steps ...

5) The SDK Manager will download the installer to the "extras" directory, under the main SDK directory. Even though the SDK manager says "Installed" it actually means that the Intel HAXM executable was downloaded. You will still need to run the installer from the "extras" directory to get it installed.

6) Run the installer inside the /sdk/extras/intel/Hardware_Accelerated_Execution_Manager/ directory and follow the installation instructions for your platform.

So all I needed to do was go to folder where my Android SDK was, opened that folder (sdk_location/sdk/extras/intel/Hardware_Accelerated_Execution_Manager) and run the silent_install.bat.

After this when I launched my emulator, it said this:

HAXM is working and emulator runs fast virt mode

and everything works as should!

You can also use some useful parameters with silent_install.bat:

  • -v Print HAXM version
  • -c Check VT/NX capability of the platform
  • -h Print usage
2018/04/06

Make sure the emulator is not running while installing HAXM. Otherwise, there will be an error which you only see when using the standalone installer but not within Android Studio or IntelliJ Idea.

2019/01/02

dism.exe /Online /Disable-Feature:Microsoft-Hyper-V

or

bcdedit /set hypervisorlaunchtype off

Other things you may need to do:

  • If using Avast? disable Enable hardware-assisted virtualization under: Settings > Troubleshooting
  • bcdedit /set nx AlwaysOn
  • sfc /scannow and reboot

Important: After anything you try, Restart the PC and try to run the HAXM installation again

2018/04/06

I faced this problem.I got the solution too.It will work.

Step 1: Go to your BIOS settings and check that INTERNET VIRTUAL TECHNOLOGY is Enabled or Disabled.

And make sure HYPER V is disabled. To disable it : a)Go to Control Panel b)Click on Programs(Uninstall a Program) c)Then click on Turn Windows features on or off , then look for HYPER-V and untick it. And Restart. If disabled then enable it.

Step 2: Try to install Intel HAXM now and restart. If It shows same problem again. go to Step 3.

Step 3: You have to disable Digitally Signed Enforcement. To disable it permanently you have to make sure that Secure Boot option is disabled in your system.

How to check ?

Answer is given in the following link. I found it in Internet.[Thanks whoever made that blog]

link : http://www.windowspasswordsrecovery.com/win8-tips/how-to-disable-uefi-secure-boot-in-windows-8-1-8.html

Step 4: Now restart again.

To disable driver signature enforcement permanently in Windows 10, you need to do the following:

1.Open an elevated command prompt instance.
2.Type/paste the following text:

     `bcdedit.exe /set nointegritychecks on`

or Windows 10

     `bcedit.exe -set loadoptions DISABLE_INTEGRITY_CHECKS`

Windows 10 disable driver signature enforcement

Restart Windows 10.

*If you somehow want to enable it again:

1.Type/paste the following text:

     `bcdedit.exe /set nointegritychecks off`
2019/08/14

This is what worked for me -

  1. Enable Virtualiztion through BIOS (F10-> System Configuration -> Virtualiztion Technology) Depending on your hardware, firmware and BIOS configuration utility the option to enable may be named something else or steps may differ. There is a free software called "Piriform Speccy" which gives information about your machine, which among other things can also be used to check if virtualization is enabled or not on your machine (see screen cap).

Check if virtualization enabled with Speccy

  1. Download HAXM intaller from Intel site. https://software.intel.com/en-us/android/articles/intel-hardware-accelerated-execution-manager

  2. If using avast, disable "Enable hardware-assisted virtualization" under: Settings > Troubleshooting by unchecking.

Do a hard boot (power button) just to be safe.

2016/01/09